מודול 13 · שיעור 1 מתוך 343/54 בקורס~16 min
שיעורי מודול (1/3)
NSEC, NSEC3, and negative proofs
NSEC, NSEC3 והוכחות שליליות
DNSSEC חייב להוכיח לא רק שקיים רשומה, אלא גם ששם או סוג נעדר. NSEC מקשר שמות בסדר ממוין ומפרט את הסוגים בשם. מאמת בודק את החתימות וההוכחות כדי לאשר תשובה שלילית. קישורי NSEC הליכה יכולים לחשוף שמות באזור.
NSEC3 מגיב שמות כדי להפוך ספירה פשוטה לפחות ישירה, אבל זה לא הצפנה. עדיין ניתן לנחש ולבדוק שמות צפויים. ביטול הסכמה יכול להפחית את העלות בתרחישי האצלה מסוימים, אבל זה משנה אילו משלחות מכוסות על ידי הוכחות. מטמון שלילי אגרסיבי יכול לאפשר לפותרים תואמים לעשות שימוש חוזר בהוכחות מאומתות עבור שאילתות בקרבת מקום.
הפניות: RFC 4034 — NSEC · RFC 5155 — NSEC3 · RFC 8198 — אגרסיבי מטמון
בדוק את ההבנה שלך
בחר את התשובה הטובה ביותר. הדוגמאות משתמשות בשמות אימון ואינן שולחות שאילתות DNS אמיתיות.
האם NSEC3 הופך את שמות האזורים לחסויים?