跳转到主要内容
模块 13 · 第 1 课(共 3)课程中的43/54~16 min
模块课程(1/3)

NSEC, NSEC3, and negative proofs

NSEC、NSEC3 和负证明

DNSSEC 不仅必须证明记录存在,而且还必须证明名称或类型不存在。 NSEC 按排序顺序链接名称并列出名称处的类型。验证者检查签名和证据以确认否定答案。行走 NSEC 链接可以显示区域中的名称。

NSEC3 对名称进行哈希处理,使简单枚举变得不那么直接,但它不是加密。可预测的名称仍然可以被猜测和测试。选择退出可以降低某些委托场景中的成本,但它会改变证明所涵盖的委托。积极的负缓存可以让兼容的解析器为附近的查询重用经过验证的证明。

参考文献: RFC 4034 — NSEC · RFC 5155 — NSEC3 · RFC 8198 — 激进缓存

检查你的理解情况

选择最佳答案。这些示例使用训练名称,并且不发送真正的 DNS 查询。

Quiz#dns.m13.l1.e1

NSEC3 是否对区域名称进行保密?

答案选项