模块 13 · 第 2 课(共 3)课程中的44/54~16 min
模块课程(2/3)
Trust anchors and automated rollover
信任锚和自动翻转
翻转并不是“改变一个键并希望互联网能够跟上”。解析器和父区域可以缓存不同时期的数据。根信任锚可以通过自动化流程进行管理。在委托中,CDS 和 CDNSKEY 让子级发布可以帮助其父级更新 DS 的信息,但须遵守父级的策略。
自动化减少了手动工作,但并没有消除检查、授权和回滚的需要。确认算法和摘要,将 DS 与 DNSKEY 进行匹配,检查签名状态,并计算更改前后的缓存窗口。
仔细的过程会说明其先决条件,发布新密钥,允许传播,更新父密钥,验证独立解析器的结果,并仅在转换完成时删除旧密钥。遵循您的注册商和 DNS 软件支持的流程,而不是盲目复制命令。
参考文献: RFC 5011 — 自动信任锚管理 · RFC 7344 — CDS/CDNSKEY · RFC 8078 — DS更新
检查你的理解情况
选择最佳答案。这些示例使用训练名称,并且不发送真正的 DNS 查询。
展期期间必须保持哪些真实情况?