মূল কন্টেন্টে যান
মডিউল 11 · 2-এর পাঠ 3কোর্সে 38/54~16 min
মডিউল পাঠ (2/3)

AXFR, IXFR, and TSIG

AXFR, IXFR, এবং TSIG

AXFR একটি সম্পূর্ণ অঞ্চল স্থানান্তর করে। সার্ভারের প্রয়োজনীয় ইতিহাস থাকলে IXFR শুধুমাত্র পরিচিত সিরিয়াল থেকে পরিবর্তনগুলি স্থানান্তর করতে পারে। এই প্রক্রিয়াগুলি অনুমোদিত সেকেন্ডারিগুলিকে তাদের কপিগুলি বর্তমান রাখতে দেয়; এগুলি অভ্যন্তরীণ অঞ্চল ডেটার সর্বজনীন ডাউনলোড হিসাবে অভিপ্রেত নয়৷

নেটওয়ার্ক নিয়ন্ত্রণ এবং সার্ভার কনফিগারেশন ব্যবহার করে পরিচিত সেকেন্ডারি সার্ভারে স্থানান্তর সীমাবদ্ধ করুন। TSIG DNS বার্তা যেমন স্থানান্তরের জন্য একটি শেয়ার্ড-কী প্রমাণীকরণ প্রক্রিয়া যোগ করে। গোপনীয়তা রক্ষা করুন, সাবধানে ঘোরান এবং ব্যর্থ বা অপ্রত্যাশিত স্থানান্তর অনুরোধগুলি নিরীক্ষণ করুন। প্রাথমিকের নাম লুকানো একটি অ্যাক্সেস-কন্ট্রোল পরিমাপ নয়।

তথ্যসূত্র: RFC 5936 — AXFR · RFC 1995 — IXFR · RFC 894 TSIG

আপনার উপলব্ধি পরীক্ষা করুন

সেরা উত্তর চয়ন করুন. উদাহরণগুলি প্রশিক্ষণের নাম ব্যবহার করে এবং প্রকৃত DNS প্রশ্ন পাঠায় না।

Quiz#dns.m11.l2.e1

কোন সংমিশ্রণটি একটি নিরাপদ অঞ্চল স্থানান্তরকে সর্বোত্তম বর্ণনা করে?

উত্তরের বিকল্প