Уроки модуля (2/3)
AXFR, IXFR, and TSIG
AXFR, IXFR и TSIG
AXFR передает всю зону. IXFR может передавать только изменения начиная с известного серийного номера, когда на сервере имеется необходимая история. Эти механизмы позволяют авторизованным вторичным серверам поддерживать актуальность своих копий; они не предназначены для публичной загрузки данных внутренней зоны.
Ограничьте передачу на известные вторичные серверы, используя элементы управления сетью и конфигурацию сервера. TSIG добавляет механизм аутентификации с общим ключом для сообщений DNS, таких как передачи. Защищайте секрет, осторожно меняйте его и отслеживайте неудачные или неожиданные запросы на передачу. Сокрытие имени основного пользователя не является мерой контроля доступа.
Ссылки: [RFC 5936 — AXFR] (https://www.rfc-editor.org/rfc/rfc5936.html) · [RFC 1995 — IXFR] (https://www.rfc-editor.org/rfc/rfc1995.html) · RFC 8945 — TSIG
Проверьте свое понимание
Выберите лучший ответ. В примерах используются обучающие имена и не отправляются настоящие DNS-запросы.
Какая комбинация лучше всего описывает безопасную передачу зоны?