מודול 11 · שיעור 2 מתוך 338/54 בקורס~16 min
שיעורי מודול (2/3)
AXFR, IXFR, and TSIG
AXFR, IXFR ו-TSIG
AXFR מעביר אזור שלם. IXFR יכול להעביר רק את השינויים מאז סדרה ידועה כאשר לשרת יש את ההיסטוריה הנדרשת. מנגנונים אלה מאפשרים למשניים מורשים לשמור על העותקים שלהם עדכניים; הם אינם מיועדים להורדות ציבוריות של נתוני אזור פנימי.
הגבל העברות לשרתים משניים ידועים באמצעות בקרות רשת ותצורת שרת. TSIG מוסיפה מנגנון אימות מפתח משותף עבור הודעות DNS כגון העברות. הגן על הסוד, סובב אותו בזהירות ועקוב אחר בקשות העברה כושלות או בלתי צפויות. הסתרת השם הראשי אינה אמצעי לבקרת גישה.
הפניות: RFC 5936 — AXFR · RFC 1995 — IXFR · RFC 8945 — TSIG
בדוק את ההבנה שלך
בחר את התשובה הטובה ביותר. הדוגמאות משתמשות בשמות אימון ואינן שולחות שאילתות DNS אמיתיות.
איזה שילוב מתאר בצורה הטובה ביותר העברת אזור מאובטח?