メインコンテンツにスキップ
モジュール 11 · レッスン 2 / 3コース内の 38/54~16 min
モジュールのレッスン (2/3)

AXFR, IXFR, and TSIG

AXFR、IXFR、TSIG

AXFR はゾーン全体を転送します。 IXFR は、サーバーに必要な履歴がある場合、既知のシリアル以降の変更のみを転送できます。これらのメカニズムにより、承認されたセカンダリはコピーを最新の状態に保つことができます。これらは、内部ゾーン データのパブリック ダウンロードを目的としたものではありません。

ネットワーク制御とサーバー構成を使用して、既知のセカンダリ サーバーへの転送を制限します。 TSIG は、転送などの DNS メッセージに共有キー認証メカニズムを追加します。シークレットを保護し、慎重にローテーションし、失敗した転送リクエストや予期しない転送リクエストを監視します。プライマリの名前を隠すことは、アクセス制御手段ではありません。

参考文献: RFC 5936 — AXFR · RFC 1995 — IXFR · RFC 8945 — TSIG

理解度を確認してください

最良の答えを選択してください。この例ではトレーニング名を使用しており、実際の DNS クエリは送信しません。

Quiz#dns.m11.l2.e1

セキュアゾーン転送を最もよく表す組み合わせはどれですか?

回答の選択肢