Modulelessen (2/3)
CAA and DANE
CAA en DANE
Specificaties: CAA, RFC 8659, DANE TLSA, RFC 6698 en DANE operationele richtlijnen, RFC 7671.
Met CAA-records kan een domein aangeven welke certificeringsinstanties er certificaten voor mogen uitgeven. Ze zijn een beleidssignaal dat certificeringsinstanties controleren; ze vervangen de accountbeveiliging of certificaatmonitoring niet.
DANE gebruikt TLSA-records om een dienst te koppelen aan certificaat- of sleutelinformatie, waarbij DNSSEC de geauthenticeerde DNS-gegevens levert waarvan de associatie afhankelijk is. Zonder een geldige DNSSEC-keten kan een klant er niet op vertrouwen dat het TLSA-record is geverifieerd. TXT, CAA en TLSA hebben verschillende formaten en betekenissen; interpreteer elk in de context van het protocol dat er gebruik van maakt.
Controleer uw begrip
Kies het beste antwoord. Deze quiz wordt lokaal uitgevoerd en stuurt geen DNS-query's naar echte domeinen.
Waar is DANE-authenticatie via TLSA van afhankelijk?