מודול 10 · שיעור 1 מתוך 334/54 בקורס~15 min
שיעורי מודול (1/3)
SPF, DKIM, and DMARC
SPF, DKIM ו-DMARC
מפרטים: SPF, RFC 7208, DKIM, RFC 6376, ו-DMARC, RFC 9989. RFC 9989 הוא מפרט ה-DMARC העדכני ביותר ומיושן RFC 7489.
מנגנוני דוא"ל אלה משתמשים ברשומות DNS, לעתים קרובות ב-TXT, אך לכל אחד יש עבודה אחרת. SPF מתאר אילו מערכות עשויות לשלוח דואר עבור דומיין. DKIM מאפשר למקלט לאמת חתימת הודעה באמצעות מפתח ציבורי שפורסם ב-DNS. DMARC משתמש בכללי יישור ומדיניות תחום כדי להנחות את הטיפול והדיווח. רשומת DNS לבדה אינה מבטיחה שהודעה מהימנה.
סקור תחביר, יישור, מדיניות ודיווח ביחד. פתח את האכיפה בזהירות, עקוב אחר שולחים לגיטימיים והימנע מפרסום רשומות SPF סותרות מרובות עבור אותו שם.
בדוק את ההבנה שלך
בחר את התשובה הטובה ביותר. חידון זה פועל באופן מקומי ואינו שולח שאילתות DNS לדומיינים אמיתיים.
איזה פרוטוקול מפרסם מפתח ציבורי ב-DNS כדי לאמת חתימת דוא"ל?